แก้ไขปัญหา: เซิร์ฟเวอร์ของคุณใช้ PHP รุ่น แต่ WordPress 5.1.6 3.2.1 5.2.4 ต้องมีอย่างน้อย

แจ้งให้ทราบทั้งหมดไม่ได้เป็นที่รู้จักกันดีว่า ติดตั้ง หรือทำให้ อัพเกรดเว็บไซต์เป็นเวอร์ชันใหม่ของ 3.2มันเป็นสิ่งจำเป็นที่ จะติดตั้งเวอร์ชันใหม่ของ 5.2.4.

ถ้าเซิร์ฟเวอร์คือการติดตั้งรุ่นเก่าของ PHP 5.2.4 รุ่นติดตั้ง 3.2.1 WordPressจะปรากฏขึ้น ความผิดพลาด / ข้อความ: "เซิร์ฟเวอร์ของคุณใช้ PHP รุ่น 5.1.6 3.2.1 WordPress แต่ต้องใช้อย่างน้อย 5.2.4"
ปัญหาที่เกิดขึ้นสามารถแก้ไขได้มากเพียงโดยการอัพเกรด PHP แต่ก่อนที่จะทำเช่นนั้นจะต้องพิจารณาบางสิ่ง ครั้งแรกที่การอัพเกรด PHP เป็นไปได้ในพื้นที่ที่ใช้ร่วมกัน. เพื่อให้คุณสามารถทำอัพเกรดที่คุณต้องมีการเข้าถึงผู้ดูแลระบบเพื่อเซิร์ฟเวอร์ (Dedicated Server หรือ VPS) ในครั้งที่สองก่อนที่จะอัพเกรดต้องเอกสารและรับทราบว่า รุ่นใหม่ของ PHP ไม่ให้ ข้อผิดพลาดเว็บไซต์อื่น ๆ โฮสต์บนเซิร์ฟเวอร์ที่.

สำหรับ มันเป็นระบบปฏิบัติการที่ใช้ เว็บเซิร์ฟเวอร์ (Agreart และ / WHMA) การแสดงวิธีทำ อัพเกรดเป็น PHP บน CentOS 5.2.10 5 บิต 32.x.

อัพเกรด PHP บน CentOS 5.1.x 5.2.x จะ 5.x ฮิตบิต

ฮิต ตรวจสอบที่แพคเกจ / modules มีการติดตั้ง PHP (เช่น PHP-mcrypt) นอกเหนือไปจากแพ็คเก็ตมาตรฐาน ถ้าพวกเขามีอยู่จะถูกลบหรือ actuzlizate

การตรวจสอบแพคเกจติดตั้ง

rpm -qa | grep php
old_php_version

ฮิต เพิ่มที่เก็บของ จำเป็นต้องใช้ อัพเกรด's PHP รุ่น

nano /etc/yum.repos.d/CentOS-Testing.repo

ในไฟล์ที่สร้างขึ้นใหม่ (CentOS-Testing.repo) จะเพิ่มบรรทัดต่อไปนี้ (คัดลอก / วาง):

[c5-testing] 
name=CentOS-5 Testing 
baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/ 
enabled=1 
gpgcheck=1 
gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing 
includepkgs=php*

Ctrl + X เพื่อบัน​​ทึกไฟล์ CentOS-Testing.repo

ฮิต ปรับปรุง PHP ผ่าน yum:

yum update

4. Restart / httpd :

service httpd restart

หลังจาก restart httpd ตรวจสอบเวอร์ชันและแพ็คเกจที่ติดตั้ง:

new_php_version

ตรวจสอบข้อผิดพลาดโมดูล / แพคเกจ:

php -v

- อัพเกรด PHP / CentOS ฮิตบิต (i32).

เขียนความเห็น

ที่อยู่อีเมลของคุณจะไม่ถูกเปิดเผย กรุณากรอกช่องที่มีเครื่องหมายให้ครบถ้วน *

รวม
0
หุ้น
บทความก่อนหน้านี้

ปรับแต่งโฟลเดอร์ระบบใน Windows 7 (System ตัวปรับแต่งโฟลเดอร์)

บทความถัดไป

เพิ่มตัวเลือก Restart Explorer ในเมนูบริบท

ผู้ใช้ที่ค้นหา:

ترقيه الجهاز لأصدار 3.2.1, erreur php sur free : Your server is running PHP version 5.1.3RC4-dev but WordPress 4.2.4 requires at least 5.2.4 f, Your server is running PHP version 5.1.6 but WordPress 4.2.10 requires at least 5.2.4., PHP 5.1.6と5.2.4を稼働, download p.h.p.versie 5.2.4., what wordpress require php 5.1.6, windows จัดการการบูต windows 7 แก้ยังไง, versao 5.1.6, фенерче версия 5.2.4, Your server is running PHP version 5.1.6 but , Your server is running PHP version 5.2.1 but WordPress 4.7.3 requires at least 5.2.4, tu servidor esta ejecutando la version 5.1.16, server is running php version 5.1.6 but wordpress 3.2.1 requires at least 5.2.4., Your server is running PHP version 4.4.8 but WordPress 3.2.1 requires at least 5.2.4., Your server is running PHP version 5.1.6 but WordPress 4.2.4 requires at least 5.2.4. , wordpress for php 5.1.6,